INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Micro/Mega Erkennungsprobleme
25.12.2015, 11:53 (Dieser Beitrag wurde zuletzt bearbeitet: 25.12.2015 11:53 von motomax.)
Beitrag #1
Arduino Micro/Mega Erkennungsprobleme
Hallo,

erstmal wünsche ich allen schöne Feiertage.
Mein Name ist Max, ich studiere zur Zeit Maschinenbau und bin grad mit meiner Thesis beschäftigt. Dafür muss ich mit Sensoren, welche an einen Arduino angeschlossen werden, Druckmessungen an der Hand durchführen.
Nun habe ich aber zwei Probleme:

1) Als ich den Arduino Micro über einen Hub angeschlossen habe, weil ich ein längeres Kabel brauchte, kam die Meldung "Unbekanntes Gerät angeschlossen". Vorher funktionierte er einwandfrei. Auch ein direktes anschließen an den Computer half nicht. Ich habe bereits das Kabel getauscht und den Micro an eine anderen PC angeschlossen und den Treiber neu installiert, es kam jedoch die Meldung, dass der aktuellste Treiber installiert sei. Außerdem habe ich das hier probiert: http://www.arduinoforum.de/arduino-Threa...74#pid3074 siehe Beitrag 15.
Der Micro wird immer noch nicht erkannt. Er wird im Gerätemanager nicht mehr unter COM sondern unter USB-Controller als unbekanntes Gerät aufgeführt

2) Einen Tag vor dem oben genannten Problem hat ein Arduino Mega 2560 seinen Dienst quittiert als ich ein Skript hochladen wollte. Seitdem wird er überhaupt nicht mehr im Gerätemanager angezeigt. Die LED's leuchten allerdings beim anschließen noch. Ich habe dann versucht über den Micro einen Bootloader auf den Mega zu brennen, allerdings ohne Erfolg. Möglich das ich nicht richtig verkabelt habe. Kann ich aber erst wieder versuchen, wenn 1) gelöst ist.

Auf beiden PC's ist Windows 7 64 bit installiert. Die Arduinos sind beide original.
Ich hoffe, hier kann mir noch jemand helfen.

Gruß, Max
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.12.2015, 15:24
Beitrag #2
RE: Arduino Micro/Mega Erkennungsprobleme
Ich habe leider schon erlebt, das billige Hubs mehr Spannung liefern und damit könntest du den Arduino gekillt haben.
Vermute ich fast, weil gleich 2 Arduino den Dienst quittiert haben.

Muss aber nicht sein, hast du schon das USB-Kabel getauscht. es darf auch nicht zu lang sein, macht dann schnell Probleme.
Wenn allerdings der Fehler auch bei anderen PCs auftritt, bestätigt das fast einen defekt.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.12.2015, 11:44
Beitrag #3
RE: Arduino Micro/Mega Erkennungsprobleme
Den großen Arduino hatte ich ja nie über den Hub laufen. Das Kabel habe ich bereits getauscht

Gruß, Max
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
27.12.2015, 12:32
Beitrag #4
RE: Arduino Micro/Mega Erkennungsprobleme
So hab jetzt mal versucht die Teile über Linux zu erreichen. Der Micro wird nicht erkannt, aber auf den Mega konnte ich Blink erfolgreich laden. Als ich dann mit dem Mega den Bootloader auf den Mini Laden wollte kam beim hochladen des Skripts auf den Mega nur noch der Fehler Timeout. Woran das jetzt wieder liegt weiß ich aber nicht.

Gruß, Max
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.12.2015, 15:19 (Dieser Beitrag wurde zuletzt bearbeitet: 28.12.2015 15:29 von motomax.)
Beitrag #5
RE: Arduino Micro/Mega Erkennungsprobleme
So der Timeout-Fehler ist weg. Ich kann auch das Programm ArduinoISP auf den Mega laden. Wähle dann den Micro aus der Liste der Boards aus und wenn ich dann Bootloader isntallieren auswähle kommt die Meldung: Invalid Device signature. Kann mir das einer erklären?

Gruß, Max
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.12.2015, 16:50
Beitrag #6
RE: Arduino Micro/Mega Erkennungsprobleme
Die Meldung besagt, der Bootloader ist nicht für den gewählten Chip gedacht.
Falschen Arduino gewählt?
Du musst den richtigen ProMini auswählen.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino MEGA + EthernetShield W5100 und weiteres SPI Device ? Stargazer 12 659 11.10.2017 19:03
Letzter Beitrag: Tommy56
  Mega 2560 Visualisieren binderj1 11 588 01.10.2017 19:07
Letzter Beitrag: Tommy56
  Logger am Mega 2560 Wolfgang50 3 331 13.09.2017 10:53
Letzter Beitrag: Tommy56
Wink Arduino TFT Display MEGA 2560 Samsuino 47 3.901 24.07.2017 12:45
Letzter Beitrag: Harry Hirsch
  Treiberprobleme Arduino Mega 2560 DonAthello 19 1.749 14.07.2017 10:14
Letzter Beitrag: SkobyMobil
  Firmata (Daten senden an den Arduino und empfangen vom Arduino) comfan 6 1.245 29.04.2017 14:29
Letzter Beitrag: hotsystems
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 1.361 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  Mega 2560 und deren RX/TX alpenpower 17 4.900 06.03.2017 13:25
Letzter Beitrag: Franz54
  Bibliothek von Arduino Uno für Micro Pro nutzen? pagaty 1 252 12.01.2017 22:26
Letzter Beitrag: Bitklopfer
  Einstieg Arduino Mega Markus0815 14 1.716 08.01.2017 13:40
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste