INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Mega + LCD03+Servos= Zucken
17.06.2015, 21:13 (Dieser Beitrag wurde zuletzt bearbeitet: 17.06.2015 21:21 von Fischermentsben.)
Beitrag #1
Arduino Mega + LCD03+Servos= Zucken
Hallo zusammen,

ich bin gerade dabei die ersten Testaufbauten für ein selbsthorizontierendes System zu basteln. Leider bin ich noch relativer Anfänger in Elektronik und habe folgendes Problem: Die Servos zucken nur!

Ist das ansteuern des LCD03 zur Ausgabe von Texten im Sketch deaktiviert, zucken die Servos nicht, sondern machen genau das, was ich will. Servos sind an ext. 5V mit Ground Stromversorgung an Arduino geschaltet. Servos laufen unter PWM Pin8+10 mit der Servo-Lib, LCD03 wird im Sketch mit Softwareserial auf PWM-Pin 2 und 3 angesteuert., Stromversorgung auch 5V extern. Außerdem ist ein Kompass (CMPS11) an I2C und 3,3V (Arduino-Stromversorgung) angeschlossen. Ich bin Ratlos. Kann es sein dass es mit dem Arduino Mega Wechelwirkungen mit SoftwareSerial und den PWM Pins gibt?

Was mache ich falsch?

Grüße aus Kaiserslautern
Benjamin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.06.2015, 22:14
Beitrag #2
RE: Arduino Mega + LCD03+Servos= Zucken
Hatte das Zucken auch.

Habe ihn dann einfach mittels "Servo.detach();" imm nach dem Drehen ausgehängt.
Wenn er wieder drehen soll hängst ihn vor dem Drehbefehl wieder mittels Servo.attach() ein.

Probier das einfach mal....

lg

Zauche
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Datenübertragung vom Arduino Mega 2560 zu Hterm Datatom 1 99 13.11.2016 23:08
Letzter Beitrag: hotsystems
  Arduino Mega 2560 läuft nicht Wolfgang50 6 191 13.11.2016 10:50
Letzter Beitrag: Wolfgang50
  Arduino Mega 2560 Manfred1981 4 196 11.11.2016 18:07
Letzter Beitrag: hotsystems
  Attiny45 Bootloader brennen mit Funduino Mega toto1975 63 2.223 23.10.2016 17:08
Letzter Beitrag: hotsystems
Question Mega 2560 defekt? triode 11 368 29.09.2016 07:21
Letzter Beitrag: hotsystems
  nrf24 an Mega 2560 jgrothe 2 167 10.09.2016 13:39
Letzter Beitrag: jgrothe
  Arduino mega 2560 mit TFT LCD Touch Shield V1 Clemens55555 17 947 02.08.2016 20:51
Letzter Beitrag: Clemens55555
  Mega: Hardware i2c bus speed (Wire.) verändern? HaWe 10 2.945 14.07.2016 20:09
Letzter Beitrag: Mathias
  (Mega) Timer 3 A, B & C Scheams 0 232 04.06.2016 17:09
Letzter Beitrag: Scheams
  DUE-MEGA über I2C Verbinden HTO 0 223 22.05.2016 10:16
Letzter Beitrag: HTO

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste