INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Mega
22.08.2014, 14:51
Beitrag #1
Arduino Mega
Hallo...

Gibt es eine Möglichkeit beim Mega-Board den Eingangspuffer zu vergrößern?
Ich bekomme leider nicht alles angezeigt was gesendet wurde...

Danke im Voraus!
Mario
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 14:59
Beitrag #2
RE: Arduino Mega
Hi,
ich nehme an, Du meinst die/eine serielle Schnittstelle, oder?
Wahrscheinlich kann man die dazu gehörende Library schon irgendwie anpassen. Allerdings würde ich eine Wette eingehen, dass da was anderes falsch läuft. Bestimmt hast Du irgendwo ein delay() an einer ungeschickten Stelle.
Im Prinzip musst Du das ganze so programmieren, dass Du die Daten mindestens so schnell verarbeitest, wie sie ankommen.
Wie immer: Coding...
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 15:18
Beitrag #3
RE: Arduino Mega
danke für die schnelle antwort!! das war es. die delay zeiten waren zu lang. jetzt funktioniert es!!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 15:25
Beitrag #4
RE: Arduino Mega
Hi,
der Fehler ist höchstwahrscheinlich sogar, dass überhaupt ein delay() vorkommt.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.08.2014, 12:30
Beitrag #5
RE: Arduino Mega
... fehler würde ich jetzt nicht sagen... ich versende via gms modul sms... wartezeiten brauche ich da schon, sonst fährt das modul nicht hoch und nimmt den pin nicht an...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino MEGA + EthernetShield W5100 und weiteres SPI Device ? Stargazer 12 560 11.10.2017 19:03
Letzter Beitrag: Tommy56
  Mega 2560 Visualisieren binderj1 11 518 01.10.2017 19:07
Letzter Beitrag: Tommy56
  Logger am Mega 2560 Wolfgang50 3 304 13.09.2017 10:53
Letzter Beitrag: Tommy56
Wink Arduino TFT Display MEGA 2560 Samsuino 47 3.609 24.07.2017 12:45
Letzter Beitrag: Harry Hirsch
  Treiberprobleme Arduino Mega 2560 DonAthello 19 1.602 14.07.2017 10:14
Letzter Beitrag: SkobyMobil
  Firmata (Daten senden an den Arduino und empfangen vom Arduino) comfan 6 1.127 29.04.2017 14:29
Letzter Beitrag: hotsystems
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 1.244 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  Mega 2560 und deren RX/TX alpenpower 17 4.679 06.03.2017 13:25
Letzter Beitrag: Franz54
  Einstieg Arduino Mega Markus0815 14 1.585 08.01.2017 13:40
Letzter Beitrag: Tommy56
  Arduino Mega startet immer wieder neu Badger1875 9 1.664 26.12.2016 17:56
Letzter Beitrag: Badger1875

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste