INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino IDE Fehler beim öffnen des Seriallen Monitors
21.12.2018, 14:34
Beitrag #1
Arduino IDE Fehler beim öffnen des Seriallen Monitors
Hallo zusammen,

ich wusste nicht in welche Rubrik ich meine Frage stellen sollte ..... wenn falsch bitte verschieben!

Ich bin vor einer Woche auf Ubuntu 18.04 umgestiegen und seitdem verzweifle ich ...
Die Arduino IDE funktioniert aber der Serielle Monitor nicht!
Jetzt habe ich zig Stunden im Netz gelesen, und je mehr ich lese desto weniger verstehe ich .....

Gibt es irgendwo eine klar verständliche Anleitung in Deutsch wie ich die Einstellungen für den Seriellen Monitor und den zugriff auf die USB Schnittstellen machen muss?

Wenn ich mich z.B. der Gruppe dialout zufügen möchte mit dem Befehl:
usermod -a -G dialout benutzername
bekomme ich immer die Fehlermeldung Benuzer kann nicht gesperrt werden

Kann mir da jemand helfen?

Gruß Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.12.2018, 14:44
Beitrag #2
RE: Arduino IDE Fehler beim öffnen des Seriallen Monitors
usermod
Zitat:Es ist nicht möglich, den aktuell eingeloggten Benutzer zu bearbeiten.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.12.2018, 15:39
Beitrag #3
RE: Arduino IDE Fehler beim öffnen des Seriallen Monitors
(21.12.2018 14:44)Tommy56 schrieb:  usermod
Zitat:Es ist nicht möglich, den aktuell eingeloggten Benutzer zu bearbeiten.

Gruß Tommy

Hallo Tommy,

danke der Hinweis hat jetzt zum Erfolg geführt:
mit dem Befehl: sudo addgroup xyz tty bzw dialout konnte ich mich den Gruppen zuweisen ...

aber das kann noch nicht alles gewesen sein, weil ich beim öffnen de Seriellen Monitors immer noch die Fehlermeldung:

Fehler beim Öffnen des seriellen Ports '/dev/ttyS0'. Schauen Sie in die Dokumentation unter http://playground.arduino.cc/Linux/All#Permission

auf dieser Seite babe ich folgendes gemacht:
1. den Gruppen bin ich ja schon beigetreten ....
2. - dmesg | tail
Ergebniss:
[ 3662.244507] usb usb3-port3: Cannot enable. Maybe the USB cable is bad?
[ 3662.244532] usb usb3-port3: unable to enumerate USB device
[ 3662.372972] usb 8-2: device descriptor read/64, error -71
[ 3662.480518] usb usb8-port2: attempt power cycle
[ 3663.588543] usb usb3-port3: Cannot enable. Maybe the USB cable is bad?
[ 3663.964499] usb 8-2: new full-speed USB device number 64 using xhci_hcd
[ 3664.153526] usb 8-2: Device not responding to setup address.
[ 3664.383469] usb 8-2: Device not responding to setup address.
[ 3664.496499] usb 7-3: new full-speed USB device number 41 using ohci-pci
[ 3664.588507] usb 8-2: device not accepting address 64, error -71

und dann weiss ich nicht weiter

Gruß Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.12.2018, 19:08
Beitrag #4
RE: Arduino IDE Fehler beim öffnen des Seriallen Monitors
Ich nutze zwar streckenweise LINUX, aber dort nicht die IDE.
Da werden Andere mehr Erfahrung haben.

Gruß Tommy

PS: Richtiges USB-Kabel dran? Welcher USB-Chip auf dem Arduino?

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2018, 19:26
Beitrag #5
RE: Arduino IDE Fehler beim öffnen des Seriallen Monitors
Hallo zusammen,

ich möchte euch jetzt das Ergebnis meiner 2 tägigen Recherche für das Problem mit dem Seriellen Monitor berichten.
Die Gute Nachricht ist: ES LÄUFT Big GrinBig Grin

Nochmal kurz was ich gemacht habe:
Ich bin vor einer Woche auf Ubuntu 18.04 umgestiegen. Geschäftlich habe ich Ubuntu schon lange im Einsatz, da allerdings 16.04.

Also habe ich die Arduino IDE aus der Ubuntu- Software installiert. Zunächst machte es den Anschein dass alles läuft bis zu dem Punkt des Seriellen Monitors. Dieser wurde immer mit folgendem Fehler geöffnet;
Fehler beim Öffnen des seriellen Ports '/dev/ttyS0'. Schauen Sie in die Dokumentation unter http://playground.arduino.cc/Linux/All#Permission

Die Anweisungen des angegebenen Links habe ich, so weit ich verstanden habe durchgearbeitet, aber leider ohne Erfolg. Der Fehler kam immer wieder!

Irgendwann hatte hatte ich die Nase voll und habe die IDE komplett wieder entfernt, habe mir die letzte Version direkt von der Arduino Seite heruntergeladen und über den Terminal installiert und siehe da .... es funktioniert.
Wichtig nach der Installation ist nur noch, dass man als Benutzer der Gruppe "dialout" beitritt.
Da hatte ich anfangs auch meine Schwierigkeit, aber Dank Tommy konnte ich auch das Problem lösen!

Was mir hinterher aufgefallen ist, war das die Bezeichnung der Arduino IDE im Ubuntu-Software eine andere Bezeichnung hat,
nämlich Arduino mahal119 hat.
Darüber konnte ich aber im Internet nichts finden.

Vielleicht kann ich mit meiner Erfahrung jemanden weiterhelfen ....

Gruß Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.12.2018, 19:34 (Dieser Beitrag wurde zuletzt bearbeitet: 23.12.2018 19:42 von Tommy56.)
Beitrag #6
RE: Arduino IDE Fehler beim öffnen des Seriallen Monitors
Erst mal Glückwunsch, dass Du es zum Laufen bekommen hast.
Zu den Versionen kann ich leider auch nichts sagen.

Gruß Tommy

Edit: Das Ubuntu-Wiki nimmt als Download auch die Arduino-Seite.

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.12.2018, 12:42
Beitrag #7
RE: Arduino IDE Fehler beim öffnen des Seriallen Monitors
Gut zu wissen ,,,, Danke

Gruß Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Falsche Ergebnisse beim potenzieren Marco.R 4 237 19.11.2020 07:41
Letzter Beitrag: Marco.R
  Nextion Fehler king_MJ 3 718 27.06.2020 17:36
Letzter Beitrag: Tommy56
  433 MHz Transmitter SX1278: Merkwürdigkeit beim Empfang GuaAck 5 599 20.06.2020 22:20
Letzter Beitrag: hotsystems
  Fehlermeldung beim Sketch hochladen heino_m 12 1.618 28.05.2020 18:25
Letzter Beitrag: Tommy56
  Fehler bei delay über 32767 Kleingärtner 5 748 07.05.2020 18:51
Letzter Beitrag: Kleingärtner
  Wo ist der RxD1 beim Wemos D1 mini? DO3GE 3 598 03.05.2020 12:33
Letzter Beitrag: Fips
  Fehler bei eigener Library Samu_wo 4 684 20.04.2020 15:51
Letzter Beitrag: Samu_wo
  Verschiedene Spannungen beim Schalten von Relais? Wosch 4 686 19.04.2020 16:33
Letzter Beitrag: Tommy56
  Fehler beim Kompilieren Lunge 6 954 09.04.2020 14:07
Letzter Beitrag: MicroBahner
  Timeout beim Hochladen freak76 5 919 06.04.2020 08:54
Letzter Beitrag: GuaAck

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste