INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle
15.10.2016, 21:47
Beitrag #1
Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle
Hallo,

ich möchte mit einer Terminal-App auf dem Tablet Medion Life-Tab P9516 Daten über die USB-Schnittstelle von einem Arduino Esplora empfangen.
Habe mehrere Terminal-Apps installiert.

Leider empfängt keines davon Zeichen vom Arduino Board, jedoch können alle Zeichen zum Arduino Board senden.
Hat jemand eine Idee, was das Problem sein könnte?

Speicher, Tastatur und Maus funktionieren an der Usb-Schnittstelle.
Da ein Terminalprogramm meldet, dass ein Device "Arduino Esplora 2341:803C" angeschlossen ist, gehe ich davon aus, dass die Hardware i.O. ist.

----------------

Log-Anzeige des Terminalprogramms:
UsbManager = android.hardware.usb.UsbManager@410f0750
device MD_LIFETAB_P9516, manufacturer MEDION, model MD_LIFETAB_P9516, cpu armeabi-v7a
android 4.0.3, sdk 15
usb device: 1, v: p 2341:803C, n /dev/bus/usb/002/004, ic 3, id 000007D4
Arduino Esplora 2341:803C

----------------

Das meldet die App USB Detective:
Device 0
Name: /dev/bus/usb/002/004
class: Communication and CDC Control
Product ID: 32828
Vendor ID: 9025
Vendor Name: null
Interface count: 3

Interface 0
Interface Protocol: 0
Interface Subclass: 2
Endpoint Count: 1

Interface 1
Interface Protocol: 0
Interface Subclass: 0
Endpoint Count: 2

Interface 2
Interface Protocol: 0
Interface Subclass: 0
Endpoint Count: 1

----------------

Gruß,
Manfred
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.10.2016, 22:00
Beitrag #2
RE: Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle
(15.10.2016 21:47)MSchroeder schrieb:  ich möchte mit einer Terminal-App auf dem Tablet Medion Life-Tab P9516 Daten über die USB-Schnittstelle von einem Arduino Esplora empfangen.
Habe mehrere Terminal-Apps installiert.

Leider empfängt keines davon Zeichen vom Arduino Board, jedoch können alle Zeichen zum Arduino Board senden.
Hat jemand eine Idee, was das Problem sein könnte?

was für ein Sketch läuft denn auf deinem Esplora, oder anders, was soll dieser zurücksenden ?

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Gruß Dieter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.10.2016, 22:18
Beitrag #3
RE: Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle
(15.10.2016 22:00)hotsystems schrieb:  
(15.10.2016 21:47)MSchroeder schrieb:  ich möchte mit einer Terminal-App auf dem Tablet Medion Life-Tab P9516 Daten über die USB-Schnittstelle von einem Arduino Esplora empfangen.
Habe mehrere Terminal-Apps installiert.

Leider empfängt keines davon Zeichen vom Arduino Board, jedoch können alle Zeichen zum Arduino Board senden.
Hat jemand eine Idee, was das Problem sein könnte?

was für ein Sketch läuft denn auf deinem Esplora, oder anders, was soll dieser zurücksenden ?

Der Sketch macht nur noch ein Minimum:
In einer Schleife von 1 sek.
- LED blinkt blau
- Wird ein Zeichen Empfangen leuchtet LED rot
- Wird kein Zeichen empfangen wird Text gesendet: Serial.write("Kein Byte empfangen");

Der Text "Kein Byte empfangen" wird auf Windows-PCs in Monitor-Programmen angezeigt, auf meinem Tablet nicht.

Manfred
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  USB Schnittstelle am Mega Franz54 7 288 27.03.2018 21:02
Letzter Beitrag: Franz54
  PWM Problem, Ventilator macht Geräusche malsehen 8 563 25.02.2018 20:16
Letzter Beitrag: malsehen
  Schrittmotor a4988 Problem iceweasel7 15 1.320 02.01.2018 16:16
Letzter Beitrag: iceweasel7
  Servo Problem Winkel ansteuerung HaiAusDerDOse 7 675 22.09.2017 16:34
Letzter Beitrag: MicroBahner
  Anfänger Problem Lil-De 3 884 16.08.2017 09:47
Letzter Beitrag: Enno62
Bug Hardware Problem (!) Gandalf 34 3.362 06.11.2016 07:29
Letzter Beitrag: Pardini
  ISP Schnittstelle auf Arduino UNO R3 JoMei 2 886 02.06.2016 15:50
Letzter Beitrag: JoMei
  Problem mit adafruit motor shield Philthy 13 3.648 22.12.2015 15:27
Letzter Beitrag: hotsystems
  Bootloader/Port/Programmer Problem mit altem Diecimila HaWe 7 2.481 29.07.2015 13:10
Letzter Beitrag: HaWe
  FTDI FT232R Problem BennIY 5 2.544 07.07.2015 22:38
Letzter Beitrag: BennIY

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste