INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino DUE mit W5100 Shield
15.02.2016, 11:26
Beitrag #1
Arduino DUE mit W5100 Shield
Hallo An alle

Ich möchte gern einen Arduino DUE mit einem Ehernet Shield W5100 betreiben.
Als IDE habe ich die 1.6.7, bekomme aber keine Verbindung mit dem Schield zu meinem Netzwerk.

Das Shield und auch der Code den ich habe ist OK , da es mit einem MEGA sofort geht.
Der DUE an sich geht auch , da ich damit schon erfolgreich ein I2C Display betreibe.

Was muss ich alles beachten wenn ich das W5100 mit einem DUE betreiben möchte ?
Welche Bibliothek muss man beim DUE mit Ethernet nehmen ?


Danke
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 12:51 (Dieser Beitrag wurde zuletzt bearbeitet: 15.02.2016 12:53 von Bitklopfer.)
Beitrag #2
RE: Arduino DUE mit W5100 Shield
...gute Frage ...nächste Frage. Also der DUE läuft mit 3,3V und der Mega mit 5V...und ob das Shield mit 3,3V läuft wäre mal ein Hinweis ob das damit läuft...

Aber das scheint mir ein Hardwareproblem zu sein, deswegen hänge ich den Thread mal zur Hardware rüber.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 13:05
Beitrag #3
RE: Arduino DUE mit W5100 Shield
(15.02.2016 12:51)Bitklopfer schrieb:  ...gute Frage ...nächste Frage. Also der DUE läuft mit 3,3V und der Mega mit 5V...und ob das Shield mit 3,3V läuft wäre mal ein Hinweis ob das damit läuft...

Aber das scheint mir ein Hardwareproblem zu sein, deswegen hänge ich den Thread mal zur Hardware rüber.
lgbk

die ethernetkarte hat ja mit dem scetch eine ip-adresse xx.xx.xx.xx bekommen.
also ich würde erst mal einen ping auf die ip-adresse versuchen.

ping xx.xx.xx.xx

wenn der ping antwortet, dann wird es wohl nicht an der stromversorgung liegen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 13:28
Beitrag #4
RE: Arduino DUE mit W5100 Shield
Hall

Genau das geht ja nicht, also das Shield bekommt per Code keine IP , und ist nicht pingbar.
Stromversorgung schließe ich aus, ich habe die auch schon die 5 V Verbindung vom DUE zum W5100 getrennt, dann arbeitet das Shield genau so als wenn ich si dran habe.
Am Shield sehe ich Netzwerk Aktivität an der TX und RX LED.
Ich denke entweder ist bei der SPI Verbindung etwas zu ändern oder in der Bibliothek.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 13:41
Beitrag #5
RE: Arduino DUE mit W5100 Shield
(15.02.2016 13:28)crissy-98 schrieb:  Hall

Genau das geht ja nicht, also das Shield bekommt per Code keine IP , und ist nicht pingbar.
Stromversorgung schließe ich aus, ich habe die auch schon die 5 V Verbindung vom DUE zum W5100 getrennt, dann arbeitet das Shield genau so als wenn ich si dran habe.
Am Shield sehe ich Netzwerk Aktivität an der TX und RX LED.
Ich denke entweder ist bei der SPI Verbindung etwas zu ändern oder in der Bibliothek.

versteh ich nicht, wie willst du eine ethernet karte ohne ip nummer betreiben??
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 13:51
Beitrag #6
RE: Arduino DUE mit W5100 Shield
Hallo

Nein, ich will natürlich dieser Karte eine IP per Code zuweisen.
Ganau das mache ich so wie auch bei meinen 10 Anderen Arduino Mega's bei denen es ohne Probleme geht.
mit dieser Bibliothek und einem DUE bekommt das Shield keine IP, ist also nicht per Ping erreichbar.

Und genau darum geht es , wie betreibe ich ein W5100 Shield mit einem DUE...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 14:00
Beitrag #7
RE: Arduino DUE mit W5100 Shield
(15.02.2016 13:51)crissy-98 schrieb:  Hallo

Nein, ich will natürlich dieser Karte eine IP per Code zuweisen.
Ganau das mache ich so wie auch bei meinen 10 Anderen Arduino Mega's bei denen es ohne Probleme geht.
mit dieser Bibliothek und einem DUE bekommt das Shield keine IP, ist also nicht per Ping erreichbar.

Und genau darum geht es , wie betreibe ich ein W5100 Shield mit einem DUE...

war da nicht noch das ethernet pin, beim mega auf 53, ansonsten evtl. 10 oder anders?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.02.2016, 14:03
Beitrag #8
RE: Arduino DUE mit W5100 Shield
Eigentlich sind die Ports , welche das Shield verbindet beim MEGA und DUE gleich.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Schrittmotor ruckelt beim Start und im laufenden Betrieb - Arduino+Motor Shield grt35a 3 276 21.09.2016 06:56
Letzter Beitrag: Bitklopfer
  Steuerung eines Schrittmotor und eines Lüfters auf einem Shield phischmi 7 284 18.08.2016 20:58
Letzter Beitrag: phischmi
  Avr NetIO als Arduino mit Ethernet-Shield amithlon 2 538 18.08.2016 17:42
Letzter Beitrag: amithlon
  Welches WiFi-Shield? alpenpower 1 349 14.07.2016 11:19
Letzter Beitrag: alpenpower
  Motor Shield wird Heiß erwin 8 1.137 24.03.2016 11:29
Letzter Beitrag: hotsystems
  Per Keypad Shield zwischen zwei Programmen schalten Rob-LE 9 929 09.03.2016 14:27
Letzter Beitrag: iks77
  Multi functional Expansion Board Sensor Shield Astropikus 5 789 03.03.2016 22:32
Letzter Beitrag: hotsystems
  Arduino DUE und GSM Shield oniudra 1 374 08.02.2016 16:54
Letzter Beitrag: hotsystems
  Motor shield #elextro19 2 669 25.01.2016 09:24
Letzter Beitrag: #elextro19
  Ethernet Shield 2 geht nicht Mark79 4 980 19.01.2016 18:01
Letzter Beitrag: Mark79

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste