INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Anweisung "problem"
22.03.2015, 18:45
Beitrag #9
RE: Anweisung "problem"
Wie soll ich das anders rüberbringen ....
Die MAximale Distanz habe ich auf 50 cm voreingestellt
Alle Objekte die weiter als 50 cm weg sind, sind also außerhalb der Reichweite ( out of max distance range )
In diesem Fall erhalte ich als WERT dem gemessen anstand von 0 !
So und da ich in meiner Anweisung folgendes drin stehen habe
if ( Entfernung kleiner als 20 cm ) {
drehe nach links
}
ist 0 natürlich kleiner als 20!
Also er dreht mit auch bei Gegenständen die :
a) näher als 20 cm vom Fahrzeug weg sind und
b) bei Gegenständen die weiter weg als 50 cm entfernt sind

doch ich möchte das nicht ich will dass er die 0 entweder negiert ( was er nicht tut )
oder das die 0 keine 0 ist sondern von mir aus 0 = 99 oder so

Hoffe das ist ne bessere Beschreibung ;-)

Gruß

Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 19:04
Beitrag #10
RE: Anweisung "problem"
Hallo Chris,
dann habe ich dich doch richtig verstanden. dan sollte die Zeile die ich dir geschrieben habe oben an der richtigen stelle helfen. da dort der wert 0 auf 50cm gesetzt wird. Das muss nur vor der Abfrage mit den 20 cm stehen. Eine zweite Möglichkeit ist das du die 0 in der Abfrage ausklammerst in dem du Abfragst
if (Distance>0 && Distance<20){

So sollte es eigentlich auch gehen. Aber das hatte wampo oben schon ähnlich geschrieben.

Gruß Sven

Nichts auf der Welt ist unnütz, es kann im schlimmsten Fall immer noch als schlechtes Beispiel dienen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 19:27
Beitrag #11
RE: Anweisung "problem"
Ja aber genau das habe ich auch schon getestet ohne Erfolg k.a warum
Die Zeile die du mir gesendet hast und die anweisung beides bringt gar nichts schlimmer er reagiert gar nicht mehr.

Wahrscheinlich wäre es zu einfach :-)

Gibt es evtl. Andere vorschläge ?

Gruß
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 19:57
Beitrag #12
RE: Anweisung "problem"
Hallo,
ich habe mir dein Programm noch mal angesehen,
in der zeile
Serial.print(uS / US_ROUNDTRIP_CM);
wird dein Ping in cm für die Druckausgabe umgerechnet. nicht aber in der Weiterverarbeitung deines Programmes
versuch mal danach
uS=uS / US_ROUNDTRIP_CM;
einzufügen. vieleicht hilft das.

Gruß Sven

Nichts auf der Welt ist unnütz, es kann im schlimmsten Fall immer noch als schlechtes Beispiel dienen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.03.2015, 18:13
Beitrag #13
RE: Anweisung "problem"
Hi

uS=uS / US_ROUNDTRIP_CM;


Das hat geholfen !

Top, Super 1000 Dank

Gruß
Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.03.2015, 21:30
Beitrag #14
RE: Anweisung "problem"
Hallo Chris,
schön das ich helfen konnte.

Gruß Sven

Nichts auf der Welt ist unnütz, es kann im schlimmsten Fall immer noch als schlechtes Beispiel dienen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.03.2015, 01:57 (Dieser Beitrag wurde zuletzt bearbeitet: 28.03.2015 10:44 von Homer.)
Beitrag #15
RE: Anweisung "problem"
(21.03.2015 18:21)Wampo schrieb:  
(21.03.2015 18:10)Zerebrator schrieb:  Hallo

mein "Problem" wird für die meisten von Euch Trivial klingen aber ich komme ohne Eure Hilfe nicht weiter.

Folgendes:
Ich benutze die New Ping Library ( seit heute) um meine Ultraschallsensoren anzusprechen alles Prima so weit so gut.
Nur komme ich aus dem Max Distance Bereich bekomme ich ne 0 auch nicht schlecht aber meine Anweisungen an die Motoren Steuerung lauten wenn der Gegenstand sich weniger bzw. kleiner als 20 cm von dir aus befindet drehe nach links , rechts usw.
Mein Problem ist dass ich immer wieder aus dem Bereich rauskomme.
Klar ich könnte dem Range vergrößern doch das packen meine Sensoren nicht und das ist auch nicht der Sinn des ganzen sondern.....
Wie schaffe ich das mein Programm mir die0 ignoriert ? bzw. Wenn ich die 0 erhalte wie sage ich ihm nee es sind vom mir aus bei einer 0 -- 50 cm ??

Ich hoffe Ihr könnt mir hier weiterhelfen.

Gruß

Chris

Hy,
mein vorschlag

if (distance > 0 && distance < 19) { // bereich von 0 - 19 soll er links drehen
drehe motor links
}

if else (distance > 20 && distance < 50) { // bereich von 20 - 50 soll er rechts drehen
drehe motor rechts
}

else { // wenn beides nicht der fall ist motoren stoppen
motor stop
}

Allerdings gibts da ein Problem, solltest du genau zwischen den 19 und 20 stehen so das der Sensor immer hin und her springt dann zappelt auch dein motor.

Greez Wampo

Ja, genau. Ich glaube du hast ganz Recht.Blush









honor 6 hülle
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.03.2015, 08:32
Beitrag #16
RE: Anweisung "problem"
Moin Moin,
das sollte sich durch änder der abfragewerte ändern lassen.
zum Beispiel:

if (Distance > 0 && Ditance <=19 ...

und dann:

if else ( Distance > 19 && Distance <50 ) ....

Gruß Sven

Nichts auf der Welt ist unnütz, es kann im schlimmsten Fall immer noch als schlechtes Beispiel dienen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Bootloader update mit USBASP Problem sepp01 15 684 12.05.2018 17:23
Letzter Beitrag: sepp01
  C++ Library Datenübergabe Problem jose_ph 9 476 08.05.2018 14:10
Letzter Beitrag: Tommy56
  Problem mit der Textauswertung Franz54 13 510 15.04.2018 18:17
Letzter Beitrag: Tommy56
  Problem mit RIFD UID ParadoxDev 6 316 27.03.2018 12:04
Letzter Beitrag: ParadoxDev
  Problem mit OLED 0.96" Display torsten_156 5 1.828 07.03.2018 23:27
Letzter Beitrag: Tommy56
  Ucglib Library Problem Bully 26 1.200 05.03.2018 18:47
Letzter Beitrag: Tommy56
  Problem mit Wire.available() abfrage avoid 1 386 11.01.2018 13:40
Letzter Beitrag: Tommy56
  SerialComInstruments 4 Problem Darstellung Nextero 35 1.615 15.12.2017 18:51
Letzter Beitrag: ElEspanol
  Problem mit Nema17 und A4988 Philthy 6 547 08.12.2017 12:35
Letzter Beitrag: Tommy56
  Arduino -> Controllino [Problem gelöst] Cyrilsneer 17 1.482 27.11.2017 18:49
Letzter Beitrag: Franz54

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste