INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Anweisung "problem"
21.03.2015, 18:10
Beitrag #1
Anweisung "problem"
Hallo

mein "Problem" wird für die meisten von Euch Trivial klingen aber ich komme ohne Eure Hilfe nicht weiter.

Folgendes:
Ich benutze die New Ping Library ( seit heute) um meine Ultraschallsensoren anzusprechen alles Prima so weit so gut.
Nur komme ich aus dem Max Distance Bereich bekomme ich ne 0 auch nicht schlecht aber meine Anweisungen an die Motoren Steuerung lauten wenn der Gegenstand sich weniger bzw. kleiner als 20 cm von dir aus befindet drehe nach links , rechts usw.
Mein Problem ist dass ich immer wieder aus dem Bereich rauskomme.
Klar ich könnte dem Range vergrößern doch das packen meine Sensoren nicht und das ist auch nicht der Sinn des ganzen sondern.....
Wie schaffe ich das mein Programm mir die0 ignoriert ? bzw. Wenn ich die 0 erhalte wie sage ich ihm nee es sind vom mir aus bei einer 0 -- 50 cm ??

Ich hoffe Ihr könnt mir hier weiterhelfen.

Gruß

Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.03.2015, 18:21 (Dieser Beitrag wurde zuletzt bearbeitet: 21.03.2015 18:31 von Wampo.)
Beitrag #2
RE: Anweisung "problem"
(21.03.2015 18:10)Zerebrator schrieb:  Hallo

mein "Problem" wird für die meisten von Euch Trivial klingen aber ich komme ohne Eure Hilfe nicht weiter.

Folgendes:
Ich benutze die New Ping Library ( seit heute) um meine Ultraschallsensoren anzusprechen alles Prima so weit so gut.
Nur komme ich aus dem Max Distance Bereich bekomme ich ne 0 auch nicht schlecht aber meine Anweisungen an die Motoren Steuerung lauten wenn der Gegenstand sich weniger bzw. kleiner als 20 cm von dir aus befindet drehe nach links , rechts usw.
Mein Problem ist dass ich immer wieder aus dem Bereich rauskomme.
Klar ich könnte dem Range vergrößern doch das packen meine Sensoren nicht und das ist auch nicht der Sinn des ganzen sondern.....
Wie schaffe ich das mein Programm mir die0 ignoriert ? bzw. Wenn ich die 0 erhalte wie sage ich ihm nee es sind vom mir aus bei einer 0 -- 50 cm ??

Ich hoffe Ihr könnt mir hier weiterhelfen.

Gruß

Chris

Hy,
mein vorschlag

if (distance > 0 && distance < 19) { // bereich von 0 - 19 soll er links drehen
drehe motor links
}

if else (distance > 20 && distance < 50) { // bereich von 20 - 50 soll er rechts drehen
drehe motor rechts
}

else { // wenn beides nicht der fall ist motoren stoppen
motor stop
}

Allerdings gibts da ein Problem, solltest du genau zwischen den 19 und 20 stehen so das der Sensor immer hin und her springt dann zappelt auch dein motor.

Greez Wampo
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.03.2015, 18:31
Beitrag #3
RE: Anweisung "problem"
Hi

Danke für die schnelle Antwort.
Aber ;-) ich will das er ab (unter 20 ) bis 1 nach links bzw. rechts dreht alles was mehr als 20 ist fährt er gerade. Kein Stopp. Stopp ist nur in einen definierten Fall geplant
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 09:56
Beitrag #4
RE: Anweisung "problem"
Ich poste mal mein Test Prog. dazu.
Vielleicht lässt es sich so leichter weitermachen:

Code:
#include <NewPing.h>

#define TRIGGER_PIN  27  
#define ECHO_PIN     26  
#define MAX_DISTANCE 50

NewPing sonar(TRIGGER_PIN, ECHO_PIN, MAX_DISTANCE);



void setup() {    
//Setup Channel A
  pinMode(12, OUTPUT);
  pinMode(9, OUTPUT);

  //Setup Channel B
  pinMode(13, OUTPUT);
  pinMode(8, OUTPUT);  

  Serial.begin(9600);  

}

void loop() {
delay(29);                    
  unsigned int uS = sonar.ping();
  Serial.print("Ping: ");
  Serial.print(uS / US_ROUNDTRIP_CM);
  Serial.println("cm");

  digitalWrite(12, HIGH);
  digitalWrite(9, LOW);  
  analogWrite(3, 255);  
  
  digitalWrite(13, HIGH);  
  digitalWrite(8, LOW);  
  analogWrite(11, 255);    
  
  if ( uS > 0 && uS < 20 ){                        
    
  digitalWrite(12, LOW);
  digitalWrite(9, LOW);  
  analogWrite(3, 255);  


  digitalWrite(13, HIGH);  
  digitalWrite(8, LOW);  
  analogWrite(11, 255);  


  delay(10);

  
  }
  else {


delay(10);
  }
}

Gruß

Chris
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 11:52
Beitrag #5
RE: Anweisung "problem"
Hallo Chris,
Wie wäre eine if Bedingung nach der Abfrage des Sensors
if (Distance ==0 ){
Distance=50;
}

Gruß Sven

Nichts auf der Welt ist unnütz, es kann im schlimmsten Fall immer noch als schlechtes Beispiel dienen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 13:35
Beitrag #6
RE: Anweisung "problem"
Hi

habe es auch schon probiert leider bekomme ich immer noch 0 cm als Ausgabe bei über 50 cm.

Vielleich verfolge ich hier einen ganz falschen Ansatz ....
Kann ich die Anweisung in einen werte Bereich arbeiten lassen ohne dass ich die cm von 20 bis 5 einzeln eingeben muss???

also

if ( distance < 20 || distance <19 ||..... distance < 6 ){
fahre links/rechts
}

Gruß
Christoph
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 15:17
Beitrag #7
RE: Anweisung "problem"
Ups mir ist ein fehler unterlaufen ich meine natürlich

if ( distance == 20 || distance ==19 usw...

Gruß

Christoph
[/quote]
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.03.2015, 18:02
Beitrag #8
RE: Anweisung "problem"
Hallo Christoph,
irgendwie verstehe ich dein Problem nicht ganz. Ist nun die Entfernung über 50 cm oder die Abfrage unter 20 cm oder die Entscheidung ob links oder rechts ausweichen das eigentliche Problem?

Gruß Sven

Nichts auf der Welt ist unnütz, es kann im schlimmsten Fall immer noch als schlechtes Beispiel dienen.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit SD Card Library BennIY 4 186 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 210 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 832 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 454 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 593 13.06.2016 21:14
Letzter Beitrag: torsten_156
  ESP8266_01 flashen - Problem torsten_156 12 1.040 30.05.2016 20:12
Letzter Beitrag: torsten_156
  Hardwareserial/Softserial: Problem mit Superklasse tuxedo0801 10 475 19.05.2016 12:25
Letzter Beitrag: amithlon
  ESP8266 HTML Problem arduino_weatherstation 1 491 25.04.2016 21:52
Letzter Beitrag: rkuehle
  Problem mit OLED 0.96" Display torsten_156 3 534 03.04.2016 15:10
Letzter Beitrag: hotsystems
  Problem: SDFat - Das Ende einer Datei finden und Schleife beenden MartinK 4 486 01.04.2016 05:49
Letzter Beitrag: MartinK

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste