INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Anfängerfrage !!!! LCD zeigt keinen Text!
13.04.2015, 21:07
Beitrag #1
Sad Anfängerfrage !!!! LCD zeigt keinen Text!
Hi Leute,
habe meine ersten Gehversuche mit dem Arduino-Board gemacht.
Bin auch Elektronik-Greenhorn, habe aber großen Spass am Arduino gefunden Smile

Nun zu meiner Frage:
Habe aus dem MAKER-Kit die Schaltung mit dem LCD-Display aufgebaut (S. 89) und dazu den Programmcode (S. 91) zur Darstellung eines ersten Textes abgetippt.

An den USB-Anschluss angeschlossen wird das LCD-Display beleuchtet, ich bekomme aber keinen Text auf dem Display dargestellt.

Da ich den Programmcode korrekt abgetippt habe, ist meine bescheidene Vermutung, dass irgendein Kabel vielleicht nicht richtig im Bread steckt ??

Die Anschlüsse dürften auch alle nach der Vorgabe gesteckt worden sein.

Wer hat vielleicht eine Idee, was noch nicht ganz korrekt gemacht wurde ??

Bin für jeden Tipp dankbar!

Grüße, Lars
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 09:16 (Dieser Beitrag wurde zuletzt bearbeitet: 14.04.2015 09:30 von Tomodachi.)
Beitrag #2
RE: Anfängerfrage !!!! LCD zeigt keinen Text!
Hi Kurti,

schönen Dank für Deine Idee.

Ich habe den Poti in beide Extreme gedreht, aber es hat sich nichts geändert.
Hintergrundbeleuchtung vorhanden, schwarze Kästchen oder irgendein Text o. ä. nicht in Sicht :-(

Ich habe die Steckleiste zum Display nicht verlötet, sondern nur in das Board gesteckt. Daher hab ich als nächstes vermutet, dass die Kontakte zum Display nicht ausreichend sind. Nachdem ich die Steckkontakte nochmal überprüft habe
und teilweise minimal in Richtung Bread gedrückt habe... hat sich leider nichts geändert :-(
Reset-Taster hab ich auch schon ausprobiert.

Habe noch eine Vermutung:
Habe mit dem Original Poti (laut Literatur: Trimmer) aus dem Maker-Kit meine Probleme gehabt (liegend).
Hatte es in einem der ersten Experimente gleich mal "zerdrückt", so dass ich mir
nun ein stehendes Poti zugelegt habe. Die Steckkontakte sind dicker als z. B. von den LED, so dass ich das Poti nicht richtig hineingesteckt bekomme (vermute ich). Es ist jedenfalls meistens recht locker. Ich glaube, dass es daran liegt ...

Drücke ich auf das Poti drauf während ich bis zum Anschlag drehe, sehe ich in der oberen Reihe tatsächlich schwarze Kästchen! Teilerfolg ??

Habe auch den Programmcode nochmal übertragen. Keine Fehlermeldung (Hab das Programm nun zehnmal auf Fehler kontrolliert), aber auch kein Erfolg Sad


(14.04.2015 06:02)kurti schrieb:  Moin,
wenn das Display gar nichts zeigt, solltest Du als erstes den Kontrast kontrollieren.
Selbst ohne Programm sollten schwarze Kästchen zu sehen sein.

Gruss
Kurti
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 08:43
Beitrag #3
Thumbs Up RE: Anfängerfrage !!!! LCD zeigt keinen Text!
Habe ein wenig Respekt vor dem Löten, da ich erstens ÜBERHAUPT KEINE Erfahrung damit habe, auch gar keinen Lötkolben und weiter auch noch recht viel für meine Erstausstattung gezahlt habe, wie ich beim Durchstöbern der Foren gesehen habe. Da gibts ja teilweise die Bauteile, Sensoren etc. für kleines Geld, wenn man auch auf Nachbauten zurückgreift. Das Starter-Kit ist doch schon ganz schön teuer dagegen...
Aber was hilfts, nun hab ichs angeschafft und werde mich wohl ans Löten wagen.
Confused
Mal schauen, wo und was es da so gibt...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 13:14
Beitrag #4
Rainbow RE: Anfängerfrage !!!! LCD zeigt keinen Text!
Leute, das ist ja nett Big Grin

Ich denke, dass ein persönlicher Kontakt wirklich viel bringen würde
Leider ist es nicht soo nah (Ruhrgebiet).
Aber ich bin platt Blush

Ich werde mal sehen, wie ich mein Board selber zerstören kann Dodgy

Grüße, Lars
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 14:57
Beitrag #5
RE: Anfängerfrage !!!! LCD zeigt keinen Text!
Wo denn im Pott? Soo weit weg davon wohne ich nicht und könnte ebenfalls Löthilfe anbieten.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.04.2015, 07:39
Beitrag #6
RE: Anfängerfrage !!!! LCD zeigt keinen Text!
Habe mich jetzt erstmal dazu entschlossen, weitere Kabel zu kaufen und die Brücken damit zu ersetzen. Das LCD-Display lasse ich (hoffentlich) von einem Kollegen meines Vaters löten. Wenn das geschehen ist schauen wir mal, ob's funktioniert.
Sleepy
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Schnellanleitung: Formatierten Text posten Scheams 1 251 12.11.2016 17:01
Letzter Beitrag: ardu_arne
  haben die auf der Insel keinen Platz? Sloompie 4 1.801 02.03.2014 13:59
Letzter Beitrag: Sloompie

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste