INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
15.03.2015, 20:10
Beitrag #1
Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
Hallo Leute
Ich habe als Anfänger ein Problem, was ich nicht gelöst bekomme. Ich habe unter Arduino 1.0 ein Programm zum laufen gebracht, was die Library avr/pgmspace.h benutzt.
Nun habe ich auf 1.6.1 upgedatet und wollte das Programm bearbeiten ( vorhandene Textstrings ändern) und wieder compilieren. Der Vorgang wird abgebrochen mit einer Fehlermeldung das er einen Befel aus der Lib bzw. diese nicht kennt. Habe schon den ganzen Nachmittag damit verbracht aber keine Lösung gefunden, habe nun das Programm neu installiert, so das es nun wieder Jungfräulich auf der Platte ist.
Nun meine Frage an die Experten, wie bekomme ich die Avr Librarys die ja auch im Programmpaket enthalten sind wieder zum Laufen.
Über Tipps oder ein kleines Tutorial zum Thema, würde ich mich freuen.

mfg Legofriend
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.03.2015, 23:32
Beitrag #2
RE: Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
Hallo,

vermutlicherweise musst Du die fehlenden Libraries aus dem Installationspfad der Version 1.0 und dort im Ordner libraries in den Ordenr libraries unter dem Installationspfad der 1.6.1. kopieren. In deinem o. g. Fall sollte dies der Ordner pgmspace sein der unter anderem die Datei pgmspace.h enthält.

Gruss Ralf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 14 233 Gestern 21:12
Letzter Beitrag: Frank1234
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 3 77 18.03.2017 13:23
Letzter Beitrag: Tommy56
  Mein Skript macht nicht das was es soll ;( DerMatze79 4 123 16.03.2017 22:19
Letzter Beitrag: MicroBahner
  Befehl braucht viel Zeit GuaAck 5 192 14.03.2017 19:40
Letzter Beitrag: GuaAck
  Programmablauf macht nicht das was ich möchte !! ESP + Blynk b3ta 3 154 01.03.2017 14:29
Letzter Beitrag: Tommy56
  Neustart nach SD-Kartentausch erforderlich? Retian 10 353 27.02.2017 20:41
Letzter Beitrag: Retian
Rainbow File geht nicht zum compilieren!!!! Jocky 7 258 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 181 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Hilfe bei Taster huber5093 11 301 14.02.2017 19:26
Letzter Beitrag: Tommy56
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 361 02.02.2017 12:16
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste