INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
15.03.2015, 20:10
Beitrag #1
Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
Hallo Leute
Ich habe als Anfänger ein Problem, was ich nicht gelöst bekomme. Ich habe unter Arduino 1.0 ein Programm zum laufen gebracht, was die Library avr/pgmspace.h benutzt.
Nun habe ich auf 1.6.1 upgedatet und wollte das Programm bearbeiten ( vorhandene Textstrings ändern) und wieder compilieren. Der Vorgang wird abgebrochen mit einer Fehlermeldung das er einen Befel aus der Lib bzw. diese nicht kennt. Habe schon den ganzen Nachmittag damit verbracht aber keine Lösung gefunden, habe nun das Programm neu installiert, so das es nun wieder Jungfräulich auf der Platte ist.
Nun meine Frage an die Experten, wie bekomme ich die Avr Librarys die ja auch im Programmpaket enthalten sind wieder zum Laufen.
Über Tipps oder ein kleines Tutorial zum Thema, würde ich mich freuen.

mfg Legofriend
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.03.2015, 23:32
Beitrag #2
RE: Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
Hallo,

vermutlicherweise musst Du die fehlenden Libraries aus dem Installationspfad der Version 1.0 und dort im Ordner libraries in den Ordenr libraries unter dem Installationspfad der 1.6.1. kopieren. In deinem o. g. Fall sollte dies der Ordner pgmspace sein der unter anderem die Datei pgmspace.h enthält.

Gruss Ralf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Bitte um Hilfe Arduino Nano-MAX7219-PIR_Sensor Opa_Klaus 35 808 20.05.2017 21:11
Letzter Beitrag: Opa_Klaus
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 317 15.05.2017 13:17
Letzter Beitrag: DL1AKP
  Brauche Hilfe für meine Abfüllanlage/ millis() Slash96 8 291 10.05.2017 21:04
Letzter Beitrag: MicroBahner
  433mHz Funkmodule senden/empfangen nicht metzgefa 2 317 06.05.2017 13:30
Letzter Beitrag: metzgefa
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 17 797 16.04.2017 12:58
Letzter Beitrag: Jonas Lindenblatt
  SD Karte wird nicht erkannt Maxi290997 6 237 31.03.2017 06:05
Letzter Beitrag: Bitklopfer
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 641 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  Zeitschaltuhr Hilfe für RTC Anfänger 4Jordy 4 230 24.03.2017 15:23
Letzter Beitrag: MicroBahner
  Mein Skript macht nicht das was es soll ;( DerMatze79 4 293 16.03.2017 22:19
Letzter Beitrag: MicroBahner
  Befehl braucht viel Zeit GuaAck 5 310 14.03.2017 19:40
Letzter Beitrag: GuaAck

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste