INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
15.03.2015, 20:10
Beitrag #1
Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
Hallo Leute
Ich habe als Anfänger ein Problem, was ich nicht gelöst bekomme. Ich habe unter Arduino 1.0 ein Programm zum laufen gebracht, was die Library avr/pgmspace.h benutzt.
Nun habe ich auf 1.6.1 upgedatet und wollte das Programm bearbeiten ( vorhandene Textstrings ändern) und wieder compilieren. Der Vorgang wird abgebrochen mit einer Fehlermeldung das er einen Befel aus der Lib bzw. diese nicht kennt. Habe schon den ganzen Nachmittag damit verbracht aber keine Lösung gefunden, habe nun das Programm neu installiert, so das es nun wieder Jungfräulich auf der Platte ist.
Nun meine Frage an die Experten, wie bekomme ich die Avr Librarys die ja auch im Programmpaket enthalten sind wieder zum Laufen.
Über Tipps oder ein kleines Tutorial zum Thema, würde ich mich freuen.

mfg Legofriend
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.03.2015, 23:32
Beitrag #2
RE: Anfänger braucht Hilfe: Avr libs sind nach Update nicht mehr ansprechbar
Hallo,

vermutlicherweise musst Du die fehlenden Libraries aus dem Installationspfad der Version 1.0 und dort im Ordner libraries in den Ordenr libraries unter dem Installationspfad der 1.6.1. kopieren. In deinem o. g. Fall sollte dies der Ordner pgmspace sein der unter anderem die Datei pgmspace.h enthält.

Gruss Ralf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  while Schleife nach sleep mode interrupt tklaus 13 239 23.11.2016 17:40
Letzter Beitrag: Tommy56
  Arduino lässt sich nicht installieren bergfrei 4 136 20.11.2016 18:34
Letzter Beitrag: bergfrei
  Arduino Mega 2560 läuft nicht Wolfgang50 6 172 13.11.2016 10:50
Letzter Beitrag: Wolfgang50
  Ardublock übertragt nicht an IDE oder UNO R3 tobi83 5 325 16.10.2016 14:07
Letzter Beitrag: Pit
  Hilfe: IR Remote Steuerung, MSGEQ7 + RGB-LED Streifen dastob 1 117 14.10.2016 21:40
Letzter Beitrag: hotsystems
Sad Ich brauche Hilfe Prosac 4 231 09.10.2016 18:39
Letzter Beitrag: Prosac
  Upload funktioniert nicht Levi 5 237 22.09.2016 20:19
Letzter Beitrag: hotsystems
  ESP8266 tuts nicht sowerum 7 385 19.09.2016 21:01
Letzter Beitrag: sowerum
  If-Bedingung funktioniert nicht bei Serial1.write Datatom 6 222 16.09.2016 20:36
Letzter Beitrag: Datatom
  at24c256 Hilfe Gandalf 6 247 29.08.2016 18:59
Letzter Beitrag: MKc

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste