INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
06.06.2016, 12:11
Beitrag #1
Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
Moin mit'nand,

wenn ich ein beliebiges sketch aus der Beispielsammlung (oder inzwischen modifizierte Versionen) in die IDE lade, kann ich dies genau einmal kompilieren und sogar mit [Strg]-[u] hochladen. Wenn das Programm i.O. ist, läuft es sogar. Beim zweiten Kompilieren erhalte ich die Meldung

Zitat:Arduino: 1.6.8 (Windows 7), Board: "Arduino/Genuino Uno"

GetFileAttributesEx D:\Arduino\libraries\SD\src\File.cpp D:\Arduino\libraries\SD\src/SD.h: Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.

Wenn ich das sketch speichere, die IDE schließe und wieder starte, kann ich den Text modifizieren und wieder mit [Strg]-[u] hochladen - immer genau ein Mal. Recht lästig - kennt das noch jemand und weiß womöglich Abhilfe?

Der falsche Schrägstrich in der Fehlermeldung (oben von mir rot markiert) ist mir schon aufgefallen, aber ich habe keine Idee, ob das wirklich mit dem Problem zu tun hat und wer den Pfad verhunzt hat - ich war's jedenfalls nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.06.2016, 12:32
Beitrag #2
RE: Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
(06.06.2016 12:11)kl-ing schrieb:  Moin mit'nand,

wenn ich ein beliebiges sketch aus der Beispielsammlung (oder inzwischen modifizierte Versionen) in die IDE lade, kann ich dies genau einmal kompilieren und sogar mit [Strg]-[u] hochladen. Wenn das Programm i.O. ist, läuft es sogar. Beim zweiten Kompilieren erhalte ich die Meldung

Zitat:Arduino: 1.6.8 (Windows 7), Board: "Arduino/Genuino Uno"

GetFileAttributesEx D:\Arduino\libraries\SD\src\File.cpp D:\Arduino\libraries\SD\src/SD.h: Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.

Wenn ich das sketch speichere, die IDE schließe und wieder starte, kann ich den Text modifizieren und wieder mit [Strg]-[u] hochladen - immer genau ein Mal. Recht lästig - kennt das noch jemand und weiß womöglich Abhilfe?

Der falsche Schrägstrich in der Fehlermeldung (oben von mir rot markiert) ist mir schon aufgefallen, aber ich habe keine Idee, ob das wirklich mit dem Problem zu tun hat und wer den Pfad verhunzt hat - ich war's jedenfalls nicht.

...es ist allgemein bekannt das manche IDE Versionen Buggy sind....deswegen nehme ich die 1.6.5 er Version und bin Happy...
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.06.2016, 14:12
Beitrag #3
RE: Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
(06.06.2016 12:32)Bitklopfer schrieb:  ...es ist allgemein bekannt das manche IDE Versionen Buggy sind....deswegen nehme ich die 1.6.5 er Version und bin Happy...
lgbk
Herzlichen Dank für den Tipp, das war's! Jetzt ist es sogar mir allgemein bekannt...
Habe Version 1.6.9 installiert - die hat jedenfalls DIESEN Bug nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.06.2016, 16:07
Beitrag #4
RE: Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
(06.06.2016 14:12)kl-ing schrieb:  
(06.06.2016 12:32)Bitklopfer schrieb:  ...es ist allgemein bekannt das manche IDE Versionen Buggy sind....deswegen nehme ich die 1.6.5 er Version und bin Happy...
lgbk
Herzlichen Dank für den Tipp, das war's! Jetzt ist es sogar mir allgemein bekannt...
Habe Version 1.6.9 installiert - die hat jedenfalls DIESEN Bug nicht.

..oder so, ich renne da nicht jeder neuen Version hinterher solange ich das häcken kann was ich benötige...
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehler in meinem Programm Franz54 7 153 01.12.2016 23:58
Letzter Beitrag: hotsystems
  CP2102 und USB Host Shield ?? DL1AKP 0 46 01.12.2016 08:55
Letzter Beitrag: DL1AKP
  Data Logger Daten auf SD Card schreiben Crichton 12 293 22.11.2016 18:32
Letzter Beitrag: Crichton
  Arduino UNO und Ethernet Shield 2 POE und Fritzbox 3272 tr3 2 155 19.11.2016 10:46
Letzter Beitrag: tr3
  Adafruit 1,8" tft ossilampe 13 227 12.11.2016 00:07
Letzter Beitrag: ossilampe
  Kommunikation über das WiFi-Shield Flap 3 233 07.11.2016 20:20
Letzter Beitrag: hotsystems
  Adafruit 2.8" Color TFT Touchscreen mittlig1977 3 205 14.10.2016 22:23
Letzter Beitrag: Tommy56
  Fehler im Programmablauf binderj1 14 351 10.10.2016 10:29
Letzter Beitrag: StephanBuerger
  Fehler beim Kompilieren binderj1 5 293 03.10.2016 21:27
Letzter Beitrag: hotsystems
Smile Simpler Fehler bei MAP? malsehen 8 228 02.10.2016 19:46
Letzter Beitrag: malsehen

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste