INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
06.06.2016, 12:11
Beitrag #1
Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
Moin mit'nand,

wenn ich ein beliebiges sketch aus der Beispielsammlung (oder inzwischen modifizierte Versionen) in die IDE lade, kann ich dies genau einmal kompilieren und sogar mit [Strg]-[u] hochladen. Wenn das Programm i.O. ist, läuft es sogar. Beim zweiten Kompilieren erhalte ich die Meldung

Zitat:Arduino: 1.6.8 (Windows 7), Board: "Arduino/Genuino Uno"

GetFileAttributesEx D:\Arduino\libraries\SD\src\File.cpp D:\Arduino\libraries\SD\src/SD.h: Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.

Wenn ich das sketch speichere, die IDE schließe und wieder starte, kann ich den Text modifizieren und wieder mit [Strg]-[u] hochladen - immer genau ein Mal. Recht lästig - kennt das noch jemand und weiß womöglich Abhilfe?

Der falsche Schrägstrich in der Fehlermeldung (oben von mir rot markiert) ist mir schon aufgefallen, aber ich habe keine Idee, ob das wirklich mit dem Problem zu tun hat und wer den Pfad verhunzt hat - ich war's jedenfalls nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.06.2016, 12:32
Beitrag #2
RE: Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
(06.06.2016 12:11)kl-ing schrieb:  Moin mit'nand,

wenn ich ein beliebiges sketch aus der Beispielsammlung (oder inzwischen modifizierte Versionen) in die IDE lade, kann ich dies genau einmal kompilieren und sogar mit [Strg]-[u] hochladen. Wenn das Programm i.O. ist, läuft es sogar. Beim zweiten Kompilieren erhalte ich die Meldung

Zitat:Arduino: 1.6.8 (Windows 7), Board: "Arduino/Genuino Uno"

GetFileAttributesEx D:\Arduino\libraries\SD\src\File.cpp D:\Arduino\libraries\SD\src/SD.h: Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.

Wenn ich das sketch speichere, die IDE schließe und wieder starte, kann ich den Text modifizieren und wieder mit [Strg]-[u] hochladen - immer genau ein Mal. Recht lästig - kennt das noch jemand und weiß womöglich Abhilfe?

Der falsche Schrägstrich in der Fehlermeldung (oben von mir rot markiert) ist mir schon aufgefallen, aber ich habe keine Idee, ob das wirklich mit dem Problem zu tun hat und wer den Pfad verhunzt hat - ich war's jedenfalls nicht.

...es ist allgemein bekannt das manche IDE Versionen Buggy sind....deswegen nehme ich die 1.6.5 er Version und bin Happy...
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.06.2016, 14:12
Beitrag #3
RE: Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
(06.06.2016 12:32)Bitklopfer schrieb:  ...es ist allgemein bekannt das manche IDE Versionen Buggy sind....deswegen nehme ich die 1.6.5 er Version und bin Happy...
lgbk
Herzlichen Dank für den Tipp, das war's! Jetzt ist es sogar mir allgemein bekannt...
Habe Version 1.6.9 installiert - die hat jedenfalls DIESEN Bug nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.06.2016, 16:07
Beitrag #4
RE: Adafruit SD-master / logger shield: Fehler beim 2. Kompilieren
(06.06.2016 14:12)kl-ing schrieb:  
(06.06.2016 12:32)Bitklopfer schrieb:  ...es ist allgemein bekannt das manche IDE Versionen Buggy sind....deswegen nehme ich die 1.6.5 er Version und bin Happy...
lgbk
Herzlichen Dank für den Tipp, das war's! Jetzt ist es sogar mir allgemein bekannt...
Habe Version 1.6.9 installiert - die hat jedenfalls DIESEN Bug nicht.

..oder so, ich renne da nicht jeder neuen Version hinterher solange ich das häcken kann was ich benötige...
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  [gelöst] Micro SD-Card Shield an ISP? torsten_156 1 124 08.02.2018 22:24
Letzter Beitrag: Tommy56
  Hilfe bei diesen Fehler MrMagoo 22 544 06.02.2018 20:03
Letzter Beitrag: hotsystems
  <RCReceive.h> Fehler do1xxy 7 318 13.01.2018 13:21
Letzter Beitrag: do1xxy
  [Frage] Unterschied zwischen &=~ und ^= beim Bit ändern auf dem Port? avoid 13 730 11.01.2018 00:53
Letzter Beitrag: avoid
  Arduino zu MySQL via Wifi Fehler beim compilieren Franzel007 21 840 05.01.2018 20:24
Letzter Beitrag: Tommy56
  Motor Shield V3 Analog Digital Converter Nextero 5 316 19.12.2017 10:54
Letzter Beitrag: Nextero
  Fehlermeldung beim Compilieren DonCamillo 1 316 16.12.2017 21:04
Letzter Beitrag: Chopp
  Neuling Fehler beim Kompilieren guenni71 6 545 26.11.2017 16:48
Letzter Beitrag: hotsystems
  M enue System zeigt Fehler rev.antun 11 725 23.11.2017 12:22
Letzter Beitrag: rev.antun
  Fehlermeldung beim Kompilieren Arduino/Genuino Uno Otto 12 1.005 21.11.2017 20:30
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste