INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Accel Stepper Library für Schrittmotoren Problem Rampe fahren
13.10.2015, 21:03
Beitrag #1
Accel Stepper Library für Schrittmotoren Problem Rampe fahren
Hallo zusammen,
kann mir jemand bei folgendem Problem helfen oder hat jemand Erfahrung:

Habe an meinem Arduino Uno eine Schrittmotor Endstufe mit einem Schrittmotor.

Mit der Library Accel Stepper, versuche ich eine Rampe zu fahren.

stepper.setAcceleration(100); // Rampe Steps per Sekunde Sekunde
stepper.setMaxSpeed(400); // Maximale Geschwindigkeit
stepper.runToNewPosition(0); // Fahre zu Position 0
stepper.runToNewPosition(400); // Fahre zu Position 400
stepper.runToNewPosition(0); // Fahre zu Position 0
stepper.runToNewPosition(400); // Fahre zu Position 400

Das Problem ist, der Motor beschleunigt, fängt dann an zu zucken, beschleunigt weiter!

Das macht er bei jeder Rampeneinstellung. Besonders oft, wenn die Rampe klein ist!

Hoffe mir kann jemand helfen. Habe schon ein paar Tage herum probiert.

Leider ohne Erfolg!

Gruss Marcel
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino 2 schrittmotoren ansteuern super47 10 498 04.01.2017 01:35
Letzter Beitrag: renid55
  Beim Hochladen USB Problem Nils 10 300 29.12.2016 21:05
Letzter Beitrag: renid55
  Welche Library für das Funkmodul nRF24L01? alpenpower 1 133 25.12.2016 18:50
Letzter Beitrag: ardu_arne
  Library unter Linux Mint installieren atmel900 1 137 22.11.2016 14:12
Letzter Beitrag: rkuehle
  Dallas Temp Library und LiquidCrystal_i2c relay 20 545 27.10.2016 12:20
Letzter Beitrag: hotsystems
  Problem mit SD Card Library BennIY 4 256 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 245 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 942 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 532 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 736 13.06.2016 21:14
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste