INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
ATmega16A problem mit serieller Schnittstelle. Bootloader?
20.11.2014, 21:55
Beitrag #1
ATmega16A problem mit serieller Schnittstelle. Bootloader?
Hallo zusammen,

ich versuche schon seit längerer Zeit den ATmega16a über die serielle Schnittstelle zu programmieren aber bisher ohne Erfolg. Über SPI mit dem Atmel Studio ist es kein problem. Da funktioniert alles.

So, wie das Schaltbild zeigt, habe ich schon viele µC programmiert. Nur bei diesem scheitere ich. Meine Vermutung liegt am Bootloader. Ich hab schon einige Bootloader aus dem Internet ausprobiert.

Sobald ich über Arduino ein Sketch aufspielen möchte bringt er mir
Code:
avrdude: stk500_getsync(): not in sync: resp=0x00


Auch wenn mir dieser Fehler schon mehr als genug bekannt ist und ich
auch weiß was ich machen muss, scheitere ich.
Ich habe meines erachtens schon alles ausprobiert...
externen Kondensator an Reset, Baudrate, Fuse-Bits, etc.

Sollte es am Bootloader liegen, hat jemand ein funktionsfähiger den ich
ausprobieren kann?

Viele Grüße
Alex


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.12.2014, 11:11
Beitrag #2
RE: ATmega16A problem mit serieller Schnittstelle. Bootloader?
(20.11.2014 21:55)itAxel schrieb:  Hallo zusammen,

ich versuche schon seit längerer Zeit den ATmega16a über die serielle Schnittstelle zu programmieren aber bisher ohne Erfolg. Über SPI mit dem Atmel Studio ist es kein problem. Da funktioniert alles.

So, wie das Schaltbild zeigt, habe ich schon viele µC programmiert. Nur bei diesem scheitere ich. Meine Vermutung liegt am Bootloader. Ich hab schon einige Bootloader aus dem Internet ausprobiert.

Sobald ich über Arduino ein Sketch aufspielen möchte bringt er mir
Code:
avrdude: stk500_getsync(): not in sync: resp=0x00


Auch wenn mir dieser Fehler schon mehr als genug bekannt ist und ich
auch weiß was ich machen muss, scheitere ich.
Ich habe meines erachtens schon alles ausprobiert...
externen Kondensator an Reset, Baudrate, Fuse-Bits, etc.

Sollte es am Bootloader liegen, hat jemand ein funktionsfähiger den ich
ausprobieren kann?

Viele Grüße
Alex

Welchen Bootloader setzt Du denn ein (Link)? Die Arduino-IDE liefert keinen Bootloader für den ATmega16a mit. Fuse-Bits werden Dich nicht weiterbringen (höchsten den Chip bricken), die Baudrate muss einfach mit dem Bootloader übereinstimmen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit Wire.available() abfrage avoid 1 144 11.01.2018 13:40
Letzter Beitrag: Tommy56
  SerialComInstruments 4 Problem Darstellung Nextero 35 947 15.12.2017 18:51
Letzter Beitrag: ElEspanol
  Arduino Serieller Plotter Nextero 4 252 13.12.2017 14:48
Letzter Beitrag: Nextero
  Probleme Serieller Kommunikation Arduino Nextero 13 552 12.12.2017 16:47
Letzter Beitrag: hotsystems
  Problem mit Nema17 und A4988 Philthy 6 291 08.12.2017 12:35
Letzter Beitrag: Tommy56
  2 Befehle über Serielle Schnittstelle interpretieren phischmi 14 661 04.12.2017 08:52
Letzter Beitrag: phischmi
  Arduino -> Controllino [Problem gelöst] Cyrilsneer 17 937 27.11.2017 18:49
Letzter Beitrag: Franz54
  Bootloader lässt sich nicht brennen?? dobermann145 10 737 21.11.2017 22:58
Letzter Beitrag: hotsystems
Question Problem beim seriellen Einlesen von RFID-Reader Bezel 5 416 05.11.2017 22:37
Letzter Beitrag: Tommy56
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 681 22.08.2017 15:17
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste