INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
2 I2C-Devices nicht zusammen
01.03.2021, 18:32
Beitrag #33
RE: 2 I2C-Devices nicht zusammen
Ja, irgendeine unnormale Ursache musste das Verhalten ja haben.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.03.2021, 19:06
Beitrag #34
RE: 2 I2C-Devices nicht zusammen
Und genau darum brauchen immer alle Informationen.
Solche Dinge kann man nicht immer erraten.

Ich hoffe nur, dass der TO endlich mal etwas daraus gelernt hat.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.03.2021, 20:04
Beitrag #35
RE: 2 I2C-Devices nicht zusammen
(01.03.2021 18:24)SpaghettiCode schrieb:  Hi,

wenn Du von Deiner ungenauen RTC 1307 nur Vcc und nicht auch die 2 I²C-Leitungen gekappt hast, dann wird das wohl der Grund gewesen sein!
Vermutlich wird dabei die 1307 weiterhin über die ESD-Dioden versorgt, und blockiert einfach mal weiterhin die Adresse am I²C ...
So was "funktioniert" besonders gut bei ICs die wenig Strom brauchen, und auch mit niedriger Vcc laufen Tongue

Gruß André

...man sollte dabei auch daran denken das auf dem 1307 Shield auch die Pullup's für SDA und SCL vorhanden sind...dann wird je nachdem wo die R's an VCC hängen auch SDA mit SCL gebrückt...die SDA und SCL Ports im Uhrenchip haben eigentlich Open-Kollektor Ausgänge die eigentlich Hochohmig sein sollten. Aber wenn da wie vermutest auch noch ESD Dioden vorhanden sind dann kann es auch sein das die 1307 noch sendet wenn sie angesprochen wird... nichts ist unmöglich...Angel
lgbk


An alle Neuankömmlinge hier, wenn ihr Code(Sketch) hier posten wollte dann liest euch bitte diese Anleitung durch.

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.03.2021, 23:53
Beitrag #36
RE: 2 I2C-Devices nicht zusammen
Uups, Dieter.
da lag ich wohl doch daneben.
Und auf die ESD-DIODEN muss man auch erst mal kommen.
Gruß, Markus

Immer in Stress
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.03.2021, 00:08
Beitrag #37
RE: 2 I2C-Devices nicht zusammen
(03.03.2021 23:53)Chopp schrieb:  Uups, Dieter.
da lag ich wohl doch daneben.
Und auf die ESD-DIODEN muss man auch erst mal kommen.
Gruß, Markus

ja, wenn doch immer genug Infos kommen würden.

Allerdings bei I2C-Clients nur die Spannung auftrennen ist ein NO GO.
Da können wir hier lange rumraten.
Und Datenblätter sind dem TO leider auch fremd.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Mega wird nicht erkannt Gian-Luca 44 9.784 08.04.2021 17:47
Letzter Beitrag: Geisterjäger
  MKR1200 läuft nicht bei Batteriebetrieb kpc 24 2.141 05.04.2021 22:59
Letzter Beitrag: kpc
  Einfaches Projekt funktioniert am USB Anschluss, aber nicht mit Akkus PurpleLightning 3 297 05.04.2021 12:07
Letzter Beitrag: hotsystems
  Sketche lassen sich aus IDE nicht mehr hochladen Steinspiel 9 1.276 19.03.2021 19:11
Letzter Beitrag: Chopp
  Sketches lassen sich nicht mehr hochladen. Was kann ich noch tun? Tonio 3 556 19.03.2021 15:32
Letzter Beitrag: Tommy56
  Servo funktioniert nicht richtig an Arduino Nano Maxcruiser 25 3.081 14.03.2021 17:11
Letzter Beitrag: hotsystems
  Schieberegister funktioniert nicht richtig flint74 9 1.249 21.02.2021 13:35
Letzter Beitrag: flint74
  Warum sind mehrere Attiny´s nicht Synchron ? Chris_Arduino 6 2.317 02.02.2021 11:46
Letzter Beitrag: Harry
  Arduino Uno will nicht mehr wonk 35 6.404 21.01.2021 17:33
Letzter Beitrag: Tommy56
  RFID keine Daten / wird nicht erkannt Wochenendprogrammierer 79 7.982 27.12.2020 19:20
Letzter Beitrag: Wochenendprogrammierer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste